Twingate Service Incident

Incident Report for Twingate

Update

We're continuing to work with our cloud provider to identify the root cause.
Posted May 28, 2026 - 16:22 UTC

Update

We're continuing to work with our cloud provider to identify the root cause.
Posted May 28, 2026 - 13:47 UTC

Monitoring

The issue has been fixed. We are still working with cloud provider on root cause.
Posted May 28, 2026 - 12:02 UTC

Update

We are continuing to investigate this issue. We are seeing recovery and have updated the Control Plane - Authorization status to partial outage.
Posted May 28, 2026 - 10:57 UTC

Update

We are continuing to investigate this issue. We have narrowed the scope of the issue to Control Plane - Authorization.
Posted May 28, 2026 - 10:55 UTC

Update

We are continuing to investigate this issue.
Posted May 28, 2026 - 09:25 UTC

Investigating

We are currently investigating this issue.
Posted May 28, 2026 - 09:24 UTC
This incident affects: Control Plane (Authentication - Enterprise, Authentication - Social, MFA, Authorization, Connector Heartbeat).