Issues with Dashboards and Events Processing

Incident Report for Twingate

Resolved

All of internal alerts are cleared. You should not see delays/errors with dashboards and reports any longer.
Posted Apr 02, 2025 - 17:25 UTC

Monitoring

The Big Query service latencies have dropped and we see improvements with our internal dashboards.
Posted Apr 02, 2025 - 16:32 UTC

Identified

We are seeing higher latency than usual with our cloud provider's APIs to process data used for our dashboards and reports. They confirmed the issue with their service. We hope this should be resolved soon.
Posted Apr 02, 2025 - 16:19 UTC
This incident affected: Analytics (Events Processing, Reports Downloads) and Management (Network Dashboards, DNS Filtering Dashboards).