Temporary Disruption in DNS Activity Reports

Incident Report for Twingate

Resolved

This incident has been resolved.
Posted Feb 25, 2025 - 01:39 UTC

Monitoring

Recent DNS Activity is now restored and we are monitoring the system.
Posted Feb 25, 2025 - 01:28 UTC

Investigating

We're currently experiencing a temporary disruption with the DNS Activity Reports. The team is working on restoring access, and we'll have them back up shortly.
Posted Feb 24, 2025 - 22:26 UTC
This incident affected: Management (DNS Filtering Dashboards).