Twingate Admin Impacted
Incident Report for Twingate
Resolved
Twingate admin is fully functional again.
Posted Sep 26, 2022 - 22:03 UTC
Identified
Currently Twingate admin is broken.
We have identified the issue and rolling out the fix.
Posted Sep 26, 2022 - 21:59 UTC
This incident affected: Management (Admin Console).