Secure DNS Dashboards Issue

Incident Report for Twingate

Resolved

Dashboard are back to normal.
Posted Jul 29, 2024 - 22:11 UTC

Monitoring

Dashboards are gradually coming back online.
Posted Jul 29, 2024 - 21:42 UTC

Identified

Issue has been identified and we're working on a fix.
Posted Jul 29, 2024 - 21:35 UTC

Update

We are continuing to investigate this issue.
Posted Jul 29, 2024 - 21:32 UTC

Investigating

We are seeing issues with Secure DNS (Internet Security) Dashboards loading. We are investigating.
Posted Jul 29, 2024 - 21:27 UTC
This incident affected: Management (DNS Filtering Dashboards).