Recent DNS Activity Unavailable

Incident Report for Twingate

Resolved

This incident has been resolved.
Posted May 14, 2024 - 23:56 UTC

Monitoring

Recent DNS Activity screen on the Admin console is back up.
Posted May 14, 2024 - 23:43 UTC

Identified

Recent DNS Activity screen on the Admin console isn't available.
Posted May 14, 2024 - 23:38 UTC
This incident affected: Management (Admin Console).